Разное

Ремонт радиоаппаратуры и другой бытовой техники

ZyXEL Keenetic Giga 4DF38A

alex83 » 03 дек 2021, 21:13

Вот такой развеселый аппарат.


10 лет назад было куплено два таких одинаковых девайса. И все эти годы они работали нон-стоп без каких-либо нареканий. Но вот, один из них захандрил. При чем как-то неожиданно, прямо посреди дня во время работы в интернете. Аппараты эти очень мощные по функционалу и надежные, стоят сейчас очень не дешево, а потому очень бы хотелось его отремонтировать.

Симптоматика следующая.
При включении начинает работать как ни в чем небывало, всё хорошо. Но уже через несколько минут соединение с интернетом пропадает, при этом светодиод, сигнализирующий об установке соединения вполне себе горит, как ни в чем не бывало. Провайдер его по сети не видит. И даже доступ к его веб-интерфейсу по локальной сети осуществляется через пень-колоду.
Перезагрузка и фактори-ресет не помогают.

Таким образом, судя по симптомам, мы имеем дело с неисправностью, которая возникает с прогревом, т.к. чтобы заработать, прибору нужно малость остыть.

Вполне возможно, имеет место какой-то непропай, трещина или гнилое via. Нельзя исключать и аппаратный глюк какого-нибудь чипа.

Вскроем поциента...
Аватара пользователя
alex83
Имя: Александр

alex83 » 03 дек 2021, 23:02

Пока всё очень печально. Каких-то нареканий на качество пайки у меня нет, а отыскать на такой плате проблему печатного монтажа без схемы видится не реальным.

Сделано на вид всё очень качественно. Даже электролиты 105С low ESR. Впрочем, выпаивать их смысла нет, т.к. они исключительно по питанию USB-портов, а питание коммутатора и процессора обеспечивают импульсные преобразователи на обратной стороне платы.


Есть надежда на непропай коммутатора или процессора. Можно попробовать их погреть. Особенно процессор, т.к. он на шарах.

Добавлено спустя 13 минут 20 секунд:
Проверил напряжения питания. Некоторые значения несколько странноватые, но учитывая характер микросхем, думаю, они такие и должны быть. Но 3,3В немного просели.
А электролиты-то там не только по USB-портам. Это только расположение такое красивое на плате аккурат на против USB, а на самом деле это два преобразователя на 5 и 3.3В. Может всё-таки проверить их... :duma:
Аватара пользователя
alex83
Имя: Александр

alex83 » 03 дек 2021, 23:46

Хорошенько прогрел девайс и он ушел в глубокую оборону. Теперь вообще не пускает в веб-интерфейс, хотя светодиоды мигают так, как будто всё работает. Открываю окно состояния соединения, пакеты на него уходят, а вот от него ничего, ноль! Полный!

Прикольно. Похоже, плавающая неисправность оформилась в постоянную. С одной стороны это и не плохо, но опять же, смотря в чем дело.

Добавлено спустя 24 минуты 32 секунды:
Фокус-покус - кладу ладонь на радиатор процессора(он довольно горячий), придавливаю слегка и оно просерается, пакеты начинают летать туда-обратно! И веб-интерфейс появляется. Кажется, поциент хочет жить. Нужно ему помочь.

Маленький радиатор и, как следствие, циклические тепловые расширения в течение длительного времени негативно влияют на пайку шарами, а может и на сам процессор. Что характерно, заглючил девайс, который хоть и не каждый день, но отключался от электросети. А вот тому, что уже 10 лет пашет практически без выключения(редкие отрубания света не в счет) хоть бы что!
Вывод: на оставшемся рабочем аппарате срочно поставить норм радиатор на процессор.

Не исключено, что поможет прожарка, но в инетах пишут, что обычно дохнет сам проц, так что...
Аватара пользователя
alex83
Имя: Александр

alex83 » 04 дек 2021, 01:37

А радиатор там для глочки. Но на 10 лет хватило.
Снимать его нужно аккуратно. Прочно приклеен. Погреть феном на 150 и аккуратно расшатывать с переднего края чем-нибудь пластиковым.


Добавлено спустя 17 минут 30 секунд:
Всё готово для прожарки.


Добавлено спустя 37 минут 17 секунд:
В работе уже пол часа после прожарки. Коннект есть!
Аватара пользователя
alex83
Имя: Александр

rn1neb » 04 дек 2021, 02:56

У меня такой зухель заглючил прошлой весной. Пока не жарил. Нижний подогрев не использовал?
73 !
Аватара пользователя
rn1neb
Шек: FT-817ND,IC-7000,IC-7300,ZS-1,Flex-1500
Откуда: Карелия, Петрозаводск

alex83 » 04 дек 2021, 13:01

Нет, там рассыпуха, да и нечем. Надо специальный китайский столик.
Жарил, как на фото. Изоляция из алюминиевого скотча в два слоя.
Жарил примерно 15 минут. Плавно довел температуру до 350 и жарил,жарил,жарил. Под конец слегка потыкал в торец пинцетом и пристукнул(легонько) сверху. Потом плавно опустил до 100 и дал остыть. Натяжения шаров не заметил, поэтому не факт, что прожарка получилась эффективной. На этом пока решил остановится.

Добавлено спустя 2 минуты 3 секунды:
На большинстве современных более-менее цивильных плат используется бессвинцовый припой в экологических целях, а он с.ка тугоплавкий, поэтому для достижения результата жарить нужно долго и хорошо.

Добавлено спустя 1 минута 53 секунды:
11 часов - полет нормальный. В следующий раз проверю только через неделю.
Аватара пользователя
alex83
Имя: Александр

alex83 » 04 дек 2021, 13:59

А сколько твоему зухелю лет?
Аватара пользователя
alex83
Имя: Александр

NETGEAR PTV2000 не определяется

alex83 » 05 дек 2021, 22:44

Пока Keenetic Giga на прогоне, ещё один пОциент-старичок.

Если, вдруг, кто не знает, что это такое, то вот:
https://habr.com/ru/company/intel/blog/171537/
Был приобретен в 2011г. в США. Долгое время не использовался, а теперь не работает. В технике всегда так: если долго не пользуешься, то там обязательно что-нибудь закисает, ржавеет и не работает.

Но, боюсь, этот девайс мне не по зубам. Да...
А всё потому, что я даже не могу понять, неисправен он или нет. :facepalmm:

С одной стороны, он нормально включается, показывает свою мордочку на экране ТВ с сообщением о готовности к коннекту и соответствующим образом индицирует светодиодом. Более того, он без проблем меняет язык интерфейса и успешно осуществляет фактори-ресет.

Юзер-мануал: https://www.downloads.netgear.com/files ... 4Jan11.pdf

С другой же стороны, он совершенно не видится приложением, через которое должен осуществляться коннект к нему. При этом приложение это совершенно спокойно видит все соседские ТВ, поддерживающие данную технологию и предлагает к ним подключится. И даже подключается, показывая на экране соседа окно с секурити-пассворд. Это я определил по тому, что после попытки подключения соседский ТВ на некоторое время пропадает из видимости. Видимо, сосед пугается окна с пассвордом и перезагружает ТВ. Так можно докучать злым соседям. :blush:


Для работы этой устаревшей технологии требуется определенный конфиг системы. Моя система ему соответствует, всё ок. Более того, когда-то на ней данный девайс успешно эксплуатировался. Конечно, с тех пор обновились и драйвера и ПО, которое сейчас стоит самой последней версии, но тем не менее, соседские-то ТВ оно видит. :unknw:

Кароч, принимаю ставки: железо или софт.
Аватара пользователя
alex83
Имя: Александр

alex83 » 06 дек 2021, 00:27

Прежде чем лезть в потроха, начал с софта.

1. Переустановил весь интеловский WiFi-софт.
2. Попробовал разные версии приложения для коннекта, за исключением старых, которые уже не запустить.
3. Отключал сетевой экран, хоть это и без надобности, т.к. нужные приложения в исключениях, да и к теликам подключается.
4. Пробовал крутить настройки беспроводного адаптера. В частности выставил предпочтительный диапазон 2.4, т.к. об этом вроде упоминается в инструкции по эксплуатации.

5. Пробовал ходить по комнате с этим девайсом.

И ни-че-го, nothing, них.я.
Телики ловит, а поциента нет.

Вскрыл...

Сделано на вид очень какчественно.
Ни одного электролита! Ни одного, Карл! Безэлектролитные технологии! Ну нечему ломаться, нечего менять! Последней надежды лишают, с.ки! Говнище...

Что интересно, WiFi адаптер не распаян, а воткнут в USB-разъем. На спичках явно не экономили. Всё же какая-никакая ремонтопригодность.
Аватара пользователя
alex83
Имя: Александр

alex83 » 06 дек 2021, 01:53

С софтом что-то не получается...
Можно предположить, что что-то с системой. Что-то изменилось, а изменилось за годы многое.
Для исключения проблемы с системой нужна другая система поддерживающая данную технологию, а ее нет.
Возможно, нужны старые интеловские дрова. Дело в том, что этот девайс обновляет своё firmware исключительно по воздуху, а я не помню, чтобы я его обновлял. Нельзя исключать, что firmware старое и новые дрова и с ним не стыкуются. Но где их опять-таки взять... Intel их не предоставляет.

В общем, далее решено попробовать отработать аппаратную проблему девайса.
На аппаратную проблему грешу потому, что девайс не хило так греется, а во включенном состоянии его могли забывать надолго. Возможен непропай, как с Keenetic-Giga.
Но вся компьютерная часть у него работает без каких-либо видимых нареканий. Проблема в связи, а значит мог выйти из строя или заглючить его Wifi-адаптер, который тоже не холодный, а раз уж он там в виде отдельного USB-свистка, то грех его не оттестить.
Аватара пользователя
alex83
Имя: Александр

alex83 » 07 дек 2021, 00:06

Итак, продолжаем.

Вытащил свисток и воткнул в комп.
Адаптер определился как Ralink RT3572.


И я должен сказать, что он прекрасно работает. Интернет с ним просто летает!

Может проблема в интерфейсе между адаптером и системой?

Добавлено спустя 15 минут 4 секунды:
Включил девайс без Wifi-модуля. И увидел на экране ТВ сообщение о проблеме загрузки.
Значит система таки адаптер видит и общается с ним.

Добавлено спустя 17 минут 17 секунд:
Померил напряжение на USB-разъеме для очистки совести. :unknw:

Не, ну девайс, очевидно, полностью исправен и нужно возвращаться к разруливанию софтварной проблемы.
Аватара пользователя
alex83
Имя: Александр

rn1neb » 07 дек 2021, 23:02

alex83:А сколько твоему зухелю лет?
Перейти к сообщению

Не помню. Довольно много.
73 !
Аватара пользователя
rn1neb
Шек: FT-817ND,IC-7000,IC-7300,ZS-1,Flex-1500
Откуда: Карелия, Петрозаводск

NETGEAR PTV2000 определился

alex83 » 08 дек 2021, 10:55

[ пост содержит скрытую рекламу Lenovo ]

Продолжаем...
Вывел я этого маленького засранца на чистую воду.
Дело было не в бобине, кое-кто сидел в кабине.

Сервисы Интел(R) всегда отличались своей тупизной и битыми ссылками, а тут прямо подстава какая-то.
Перед тем, как оживлять этот девайс, я само-собой решил обновить весь софт с ним связанный, в том числе и драйвер моего Wifi-адаптера на ноуте.
Дело в том, что для работы этой технологии Интел(R) нужна другая технология Интел(R), которая называется Intel(R) My WiFi, дающая возможность раздавать сеть Wifi с ПК или ноута, и которая есть в пакетах обновления беспроводной сети Интел(R) Intel(R) PROSet Wireless. И естественно я пошел на сайт поддержки Интел(R).
Сначала так: https://www.intel.ru/content/www/ru/ru/ ... ducts.html
Потом так: https://www.intel.ru/content/www/ru/ru/ ... eless.html
Оттуда - сюда: https://www.intel.ru/content/www/ru/ru/ ... 20wireless
Меня тогда не сильно смутило отсутствие моего адаптера в списке поддерживаемых адаптеров к пакету обновления последней версии, т.к. других вариантов Интел(R) не предоставляет, рекомендует этот, да и версия самая последняя. Ну ОК, Интел(R), подумал я.

Всё это прекрасно обновилось и установилось, вот только драйвер не обновился. Т.е. весь интеловский WiFi-софт поставился самый последний, а драйвер адаптера беспроводной сети, как был 2011 года версии 14.2.0.10, так и остался. Заранее отследить всё это дело в диспетчере устройств я не догадался, а эта падла при установке молчит, как партизан, но об этом позже.
А всё по причине того, что мой некогда крутой адаптер за 10 лет устарел и последнее упоминание о нем в этих пакетах обновления было аж в версии 19.70, а сейчас последняя 21.40.5. Да, софт, приложения там всякие они поддерживают и обновляют, а драйвера старых устройств в пакет могут и не включать. И Intel WiDi я тоже поставил самую свежую на момент прекращения поддержки версию 4.2.29.0. И естественно, с моими старыми дровами она не заработала.

Надо ли говорить, что к пониманию всего этого я пришел не самым прямым путем.
Сначала я решил восстановить ту конфигурацию, при которой когда-то точно всё работало. Раздобыл старый пакет Intel PROSet Wireless, как раз тех времен. Был обнаружен на сайте производителя NETGEAR на странице товара. Всё снес, установил этот пакет.

С этим пакетом и всё тем же старым драйвером само собой тоже ничего не заработало. Стал искать старую версию Intel WiDi для комплекта, чтобы хоть как-то убедится, что прибор работает. А на Интеле же ничего нет, никаких старых версий, а тем более для продуктов, у которых закончилась поддержка. С сайта NETGEAR старые версии у меня не заработали вообще, даже не запустились. Выручил сайт поддержки Lenovo. Скачал какую-то 3.5.41.0. И вот с ней пошло, девайс увиделся и заработал! Т.е. я вернул связку ПО, которая на этом ПК была 10 лет назад.


Потом, решив, что дело, возможно, было в слишком свежем Intel WiDi и со старым-то теперь всё пойдет, я решил обратно накатить последний Intel PROSet, а перед этим пришлось удалить старый, т.к. обновляться оно не захотело из-за нестыковки. А вместе с ним удалился и мой драйвер WiFi. Я остался без сети. Это фиаско! :facepalmm: Чтобы не тратить время, пришлось опять разбирать этот NETGEAR и втыкать его свисток в комп, чтобы был инет. Всё-таки молодцы NETGEAR-овцы, сделали практичную вещь!
Далее при установке, новый PROSet, как бы между прочим, popup-уведомлением сообщил, что, мол, всё хорошо, но драйвер не был установлен. И тут я понял, что нас как бы на.бали...

Далее было ещё много разных экспериментов с установкой старых дров и нового Intel PROSet, но результат был неизменен, не работало ни со старым Intel WiDi ни с новым.

В общем стало понятно, что пора расходиться искать обновление Intel PROSet с более-менее свежими дровами под мой WiFi-адаптер, чтобы заработала последняя версия Intel WiDi, потому что старая хоть и работают, но только со старым Intel PROSet, к тому же подглючивает, да и вообще не айс. А сделать это оказалось не так-то просто. На Интеле нет ничего, на DELL всё те же старые дрова, на Виндовсе вообще какая-то древняя 13-я версия под Win7, через диспетчер устройств тоже не обновляется, а на всяких драйверо-помойках никакой информации о пакетах нет, не тестить же их всех подряд.

Внезапно, опять выручила поддержка Lenovo (и ничего, что у меня DELL).
Нашел там пакет Intel PROSet версии 18.40.4 с сопроводительной документацией, в которой расписано всё его содержимое. И там был существенно более свежий драйвер под мой адаптер (15.17.0.1). Какие всё-таки Lenovo-овцы молодцы, что хранят у себя всё это старое говно.
Поставил это дело, драйвер обновился и всё заработало c последней пидарской версией Intel WiDi.


Уже после я нашел вот эту драйверопомойку, на которой многие драйвера снабжены подробной информацией. Там я и подобрал последнюю версию Intel PROSet, в которой упоминается мой WiFi-адаптер и без проблем накатил её на 18.40.4. Но поскольку она тоже с драйвером 15.17.0.1, то можно было ставить сразу её.

Подведем итоги.
Для успешного определения NETGEAR PTV2000 под Win7 нужно:
  1. Снести весь старый интеловский WiFi софт (PROSet, WiDi, My WiFi, My WiFi Dashboard, всю эту шляпу).
  2. Найти и установить пакет Intel PROSet с самой последней версией драйвера вашего адаптера. Пакет должен быть именно с драйвером, т.е. после его установки версия драйвера должна апгрейдиться. При установке должен быть обязательно выбран пункт My WiFi. После установки обязательно перезагрузится и больше никаких обновлений Intel PROSet не ставить (это важно).
  3. Установить последний Intel WiDi. Мне удалось найти самый свежий 4.2.29.0. Перезагрузится. Запускать не сразу после загрузки, а подождать несколько минут, чтобы запустились все службы и прочая шляпа. После запуска первым делом в настройки и поставить галочку "Поиск прежних беспроводных дисплеев". Если обновили firmware или после обновления firmware сделали фактори-ресет, то опять таки в настройки и на кнопочку "Сброс всех настроек".
  4. Если установили Intel My WiFi Dashboard, то в настройках программы убрать автозагрузку, т.к. эта шляпа может глючить и мешать Intel WiDi.
Кароче, процессоры у Intel получаются лучше, чем всё остальное.

Вот такой получился недоремонт. Совсем диды могут сказать, что это вообще не ремонт, а какая-то фигня, но я скажу иначе. К сожалению, всё вокруг нас усложняется. Это раньше радиотехника была наукой о контактах, а теперь всё изменилось и такой ремонт тоже вполне имеет место быть, да.

ЗЫ
Так вот, что же я хочу сказать по всему этому в сухом остатке?
Я хочу сказать, что я слишком много времени потратил на всё это дерьмо.
Аватара пользователя
alex83
Имя: Александр

ZyXEL Keenetic Giga 4DF38A снова выделывается

alex83 » 10 дек 2021, 21:27

Тем временем Кинетик-Гига снова ушел в глубокую оборону.
Проработал без выключения он неделю, но через сколько времени заглючил не знаю, не было возможности проверить. При мне он нормально проработал примерно 12 часов.
Процессор у него довольно сильно греется. Этого смешного радиатора определенно недостаточно.



Попробую его прожарить на 400С. Теперь уже не жалко. :frown:

Добавлено спустя 24 минуты 35 секунд:
Прожарил. Интересно сдох процессор окончательно или нет?

Добавлено спустя 6 минут 9 секунд:
Бобик сдох. Даже не включается.

Добавлено спустя 14 минут 59 секунд:
Решил выпаять процессор для интереса.
Предположения на счет тугоплавкости оправдались. Стронуть удалось только около 400С. Возможно, мой термоэкран внес свою лепту, но без него нехорошо. А ещё там в центре мощный полигон для теплоотвода, а плата многослойная.
Аватара пользователя
alex83
Имя: Александр

alex83 » 10 дек 2021, 23:43

Когда я его демонтировал, на плате была пара розовых КП. Т.е. они нифига не были смочены припоем.

Добавлено спустя 1 минута 35 секунд:
Потренировался запаивать такое. И должен сказать, что без спец оснастки на данном корпусе шары по нормальному не накатать. КП очень мелкие. Нужен трафарет и паста. Т.е. если тупо возить жирной каплей припоя по жирному флюсу, то на КП остается очень мало припоя.

Добавлено спустя 54 секунды:
Для интереса запаял. Коммутатор только светодиодами всеми мигнет и всё на этом. Питание в порядке. На портах процессора полный nothing.

Добавлено спустя 6 минут 34 секунды:

Черные ПК слева - не разведенные КП. Такая ситуация вкупе с холодной пайкой усугубила проблему, т.к. один угол чипа фактически висел в воздухе.

Добавлено спустя 57 минут 32 секунды:
Оставшийся в живых экземпляр был доработан.
Пригодилась терморезина, которая ранее покупалась для этих целей
viewtopic.php?p=7264#p7264
Аватара пользователя
alex83
Имя: Александр

ZyXEL Keenetic Giga 4DF38A

alex83 » 11 дек 2021, 13:23

Потренировался и научился перепаивать данный чип без оснастки. Поскольку шары нормально не накатать, то нужно применять другую тактику.
В качестве флюса при "накатке шаров" нужно использовать не жирный флюс, а спирто-канифольный в достаточном количестве. И жалом паяльника нужно не елозить по КП, а макать, чтобы на КП оставались конусы припоя. Аналогично нужно поступить и с КП на плате, предварительно обязательно убрав весь старый тугоплавкий припой при помощи "косички".

Перед пайкой всё замывается спиртовым очистителем до блеска. На плату наносится теперь уже жирный флюс, который нужно наносить либо кисточкой, либо обязательно после промакнуть салфеткой, чтобы остался только его тонкий слой, иначе чип может поплыть раньше времени.

А дальше позиционируем и паяем. Чтобы чип не смещался, я подпер его краями алюминиевого термоэкрана. Нормальный припой паяется быстро и хорошо видно, как чип "плывет" и притягивается к КП.
Правда, минус в том, что чип в этом случае ложится плотно на плату и, скорее всего, будет хуже переносить какие-либо механические натяжения.

Добавлено спустя 54 минуты 56 секунд:
Итак, подведем итоги этого неудачного ремонта.
А итоги следующие:
- очевидно, там имела место холодная пайка (одна или более).
- после первой прожарки можно было сделать вывод, что дальнейшая прожарка никакого эффекта не даст, т.к. всё это "на сухую", без флюса, припой тугоплавкий, а потому никуда эта холодная пайка не денется, сколько не жарь.
- как-либо беспокоить прожариваемый чип нельзя. В процессе повторной прожарки я решил его пошевелить. Это движение хоть и было едва заметно, но заводские шары объемные, припой тугоплавкий, сухой, а потому там, видимо, что-то замкнуло и процессор сдох. После включения не было никаких признаков жизни явно из-за КЗ, а после последующих перепаек коммутатор уже проходил инициализацию нормально и мигал светодиодами.
- для повышения эффективности прожарки перед процедурой можно попробовать обмазать чип по периметру жирным флюсом и загнать флюс внутрь феном с сильным напором воздуха и температурой в районе 100С.

И мне бы, дураку, сразу взять его да перепаять, но я очканул, тупо зассал, как бы чего не вышло. :frown:
Но отрицательный результат - тоже результат. Зато я теперь умею обращаться с данными корпусами.
Аватара пользователя
alex83
Имя: Александр

alex83 » 11 янв 2022, 14:15

Внезапно, ремонт Зюкселя получил продолжение, хотя и по прежнему неудачное.
Для фана, купил у китайцев дешманский контроллер RT3052F, запаял и всё заработало. Но заработало также, как и раньше, до ремонта. Т.е. сети нет и на веб-интерфейс не зайти. С той лишь разницей, что надавливания на контроллер уже не помогают. Фактори-ресет также не помог.
При пайке на шары он встал только на 400С.


Китайский контроллер по виду зареболленный БУ, но новый даже за хорошие бабки в продаже нигде найти пока не удалось.
Делаю вывод, что проблема либо в плате(переходное?), либо брак серии этих контроллеров. И в том и в другом случае проблема походу связана с циклическим тепловым расширением.
Впрочем, нельзя исключать и каких-то особенностей конфигурации самого купленного контроллера. Откуда он выпаян неизвестно.

Для исключения варианта с платой нужна схема, а её нет.
Вложения
RT3050_5x_V2.0_081408_0902.pdf
(4.4 Мб) Скачиваний: 5
Аватара пользователя
alex83
Имя: Александр

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron